Monday 28 December 2020

BGP LAB DAY 6

 

BGP MASTER LAB

 

Task:- Understanding BGP Synchronization Rule

Dont use or advertise the routes to eBGP learned by iBGP neighbor unless and until
same are learned via other IGP .

By default BGP Synchronization Rule is not enabled.

R3 have eBGP neighbor as R1 and iBGP neighbor as R4

!!On R4 lets create an loopback and advertise to R3 via iBGP
and then check on R3 and R4 what is happening !!

Remember one thing we wont advertise the same network via any IGP

R4(config)#int loopback 400
R4(config-if)#ip address 140.0.0.1 255.255.255.0

R4(config)#router bgp 300
R4(config-router)#network 140.0.0.0 mask 255.255.255.0

R4#sh ip bgp 140.0.0.0
BGP routing table entry for 140.0.0.0/24, version 39
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2          4
  Refresh Epoch 1
  Local
    0.0.0.0 from 0.0.0.0 (40.1.4.1)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best
      rx pathid: 0, tx pathid: 0x0

Lets check on R3

R3#sh ip bgp 140.0.0.0
BGP routing table entry for 140.0.0.0/24, version 39
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     3
  Refresh Epoch 1
  Local
    4.4.4.4 (metric 435200) from 4.4.4.4 (40.1.4.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0

The route is present in Bgp table of R3

But lets check whether it is using it or not

For that lets have a look at the routing table

R3#sh ip route 140.0.0.0
Routing entry for 140.0.0.0/24, 1 known subnets
B        140.0.0.0 [200/0] via 4.4.4.4, 00:03:16

It is present in Routing table also

Now lets check on R1

R1#sh ip route 140.0.0.0
Routing entry for 140.0.0.0/24, 1 known subnets
B        140.0.0.0 [20/0] via 13.1.1.3, 00:04:34  ------------> Getting learned via R3

It is present in Routing table of R1 also

That means BGP Synchronization is disable by default

Now lets enable BGP Synchronization on R3

R3#sh run | section bgp
router bgp 300
 bgp log-neighbor-changes
 network 30.1.1.0 mask 255.255.255.0
 network 30.1.2.0 mask 255.255.255.0
 network 30.1.3.0 mask 255.255.255.0
 network 30.1.4.0 mask 255.255.255.0
 neighbor 4.4.4.4 remote-as 300
 neighbor 4.4.4.4 description **iBGP with R4**
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 13.1.1.1 remote-as 100
 neighbor 13.1.1.1 description **eBP with R1**

R3(config)#router bgp 300
R3(config-router)#synchronization
R3(config-router)#^Z
R3#

R3#sh run | section bgp
router bgp 300
 synchronization ==================================> enabled
 bgp log-neighbor-changes
 network 30.1.1.0 mask 255.255.255.0
 network 30.1.2.0 mask 255.255.255.0
 network 30.1.3.0 mask 255.255.255.0
 network 30.1.4.0 mask 255.255.255.0
 neighbor 4.4.4.4 remote-as 300
 neighbor 4.4.4.4 description **iBGP with R4**
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 13.1.1.1 remote-as 100
 neighbor 13.1.1.1 description **eBP with R1**

R3#clear ip bgp * soft in
R3#clear ip bgp * soft out

R3#sh ip route 140.0.0.0
% Network not in table
R3#
R3#sh ip bgp 140.0.0.0
BGP routing table entry for 140.0.0.0/24, version 0
Paths: (1 available, no best path)
  Not advertised to any peer
  Refresh Epoch 2
  Local
    4.4.4.4 (inaccessible) from 4.4.4.4 (40.1.4.1)
      Origin IGP, metric 0, localpref 100, valid, internal, not synchronized
      rx pathid: 0, tx pathid: 0


Now you can see the route is present in BGP but not in the routing table

Lets check on R1

R1#sh ip route 140.0.0.0              
Routing entry for 140.0.0.0/24, 1 known subnets
B        140.0.0.0 [20/0] via 2.2.2.2, 00:03:51  =========> it is stop learning via R3 and now its learning via R2

Thanks for Reading !!!!!

amartechstuff
 

Saturday 26 December 2020

BGP LAB DAY 5

 

 

BGP MASTER LAB

 Task :- Understanding BGP Autosummary

Autosummary is not enabled by default.

R1(config)#int loopback 100
R1(config-if)#ip add 100.0.0.1 255.255.255.0

R1(config)#router bgp 100
R1(config-router)#network 100.0.0.0
R1(config-router)#^Z

R1#sh ip bgp 100.0.0.0
% Network not in table

!!Now will enable Autosummary in BGP

R1(config)#router bgp 100
R1(config-router)#auto-summary
R1(config-router)#^Z

R1#sh ip bgp 100.0.0.0
BGP routing table entry for 100.0.0.0/8, version 20
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     2
  Refresh Epoch 1
  Local
    0.0.0.0 from 0.0.0.0 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best
      rx pathid: 0, tx pathid: 0x0

Also lets check on R2

R2#sh ip bgp 100.0.0.0
BGP routing table entry for 100.0.0.0/8, version 20
Paths: (1 available, best #1, table default)
  Advertised to update-groups:
     3
  Refresh Epoch 1
  100, (received & used)
    1.1.1.1 from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, external, best
      rx pathid: 0, tx pathid: 0x0

R2#ping 100.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/36 ms

Thanks for Reading !!!!

amartechstuff






Thursday 24 December 2020

SPANNING TREE PROTOCOL INTERVIEW Q&A

Question 1 –What is Spanning Tree Protocol (STP) and the use of STP ??

Answer-

Spanning Tree Protocol is a open standard LAYER 2 protocol - IEEE 802.1D which runs on Switches .

On all Cisco Switches it is enabled by default.

In layer 2 network whenever you go for redundancy; layer 2 loops can be created

STP avoids such L2 loops by blocking a port on the loop.

Question 2 –How STP Works OR Explain STP Operations ?

Answer-

Out of all the switches one switch will be elected as Root Bridge(RB) and all other switches will act as  Non Root Bridge (NRB)

All the switches will send BPDUs i.e hellos on all ports after every 2 secs.

NRB will always listen for BPDUs from the RB.

If NRB receives BPDUs from RB from more than one port it will came to know that there is a loop & it will block all ports except one port through which the cost is less i.e Root Port.

Eliminate the loop in the network.
 

Question 3 – What is the Spanning tree path cost value?

Answer-

This cost value is inversely proportional to the bandwith .
     Bandwidth     Cost
      10 Mbps   -    100
      100 Mbps -    19
      1 Gbps   -         4
      10 Gbps  -        2

Question 4 –How is the election of the Root Bridge done ?

Answer-


Election of the Root Bridge is based on Bridge ID .

The switch with lowest Bridge ID will be elected as Root Bridge.

Bridge ID is 8 Bytes .

Bridge ID = Bridge Priority + Bridge MAC

Bridge Priority = 2 Bytes , Default Bridge Priority is 32768

Bridge MAC ie. Mac address is 6 Bytes .

Question 5a –In this scenario if Switch 1 is root bridge and all the ports of all the switches have bandwidth of 100 Mbps then which port will be blocked
 - switch 2 fa0/2 or switch 3 fa0/2 ?




Answer-


Switch 3 Fa0/2  

Question 5b –In this scenario if Switch 1 is root bridge and all
the ports of all the switches have bandwidth of 100 Mbps then on Switch 4 which port will be blocked ?



Answer -

Switch 4 Fa0/2 

Question 5c –In this scenario if Switch 1 is root bridge and all the
 ports of all the switches have bandwidth of 100 Mbps then on Switch 2 which port will be blocked ?



Answer -

Switch 2 Fa0/7

Root Port Selection

lower cost

Forwarding switch (i.e upstream switch) bridge id

Port Priority of the upstream switch (not local port number)

Port number of the upstream switch (not local port number)

 

Question 6 – What are the different port states in STP?

Answer -


Disabled – A port in the disabled state does not take part in the STP.

Listening – A port in listening state prepares to forward data frames without populating the MAC address table. The port sends and listens  to BPDUs to make sure no loops occurs on the network

Learning– A port in the learning state populates the MAC address table but doesn’t forward data frames. The port still sends and receives BPDU messages as  in the listening state.

Forwarding – The port in the forwarding state can now send and receive data frames, collect MAC addresses in its address table, send and receive BPDU messages.
     This port is now a fully functioning switch port within the spanning-tree topology.

Blocking – A port in the blocking state does not forward frames.
      It only listens to BPDU messages. The function of the blocking      state is to prevent the use of looped paths.
 

Question 7 – What is the default time a port takes to transit from the blocking state to forwarding state ?

Answer -


The default time a port takes to transit from the blocking state to forwarding state is 50 seconds.

Max Age = 20 secs
Listening = 15 secs
Learning = 15 secs 

Question 8 – Explain Root Guard ?

Answer -


Root guard is used to protect root bridge .

Root guard stops a new switch introduced in the network with a lower bridge ID to become a root bridge.

If a port with root guard feature enabled receives a superior BPDU ,it moves the port into root-inconsistent state (which is somewhat similar to listening state)

Thus the current Root Bridge retains its status.

Configuration
        SW(config)#int fa0/24
        SW(config-if)#spanning-tree guard root
 

Question 9 –Explain Spanning tree Portfast ?

Answer -


Portfast is a enhancement feature of STP which speed up the STP convergence on access ports.
 It actually causes the spanning-tree forwarding state immediately bypassing the listening and learning states.
It is used on access port only where single workstation is connected .
Configuration
       SW(config)# int fa0/24
       SW(config-if)# spanning-tree portfast
        OR
       SW(config)#spanning-tree portfast default   this will enable
                                                                                all the access port in portfast

Question 10 –Explain BPDU Guard ?

Answer -


When we enable portfast on a port , we do not expect BPDUs on that port.

Incase a switch is connected by mistake on the port where portfast is enabled a loop can form (since when we configure portfast we disable STP on that port)

So to protect from such scenario we can enable BPDU guard on the port so that once a BPDU is received on the portfast port the port moves into err-disable mode i.e shutdown and it will not move the traffic . 

Thanks for Reading 

amartechstuff

Saturday 19 December 2020

Cisco Packet Tracer | Configure IP address to PC and Server | Ping test


 

It is very easy to Configure IP address to a PC and Server in Cisco Packet Tracer 

Simply Click on the icon of the PC or Server 

and refer the snapshot 





By clicking on Command Prompt option you will get an command prompt by using which you can

perform ping test and various stuff

 

 

Thanks for reading !!!!!

amartechstuff 



Friday 18 December 2020

Cisco Packet Tracer Lab - Basic Switch Configuration | Hostname | MOTD | Password


 

1) Configure the hostname of the Switch as SW1

2)  Set a message of the day (MOTD) banner  for the switch -

*************************************************

Only Authorized Users Allowed 

*************************************************

3)  Configure a 

line console password - India@123

line vty - cisco

enable secret password - Cisco@123

==================================================

Solution 

==================================================

1) Configure the hostname of the Switch as SW1

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW1
SW1(config)#exit

2) Set a message of the day (MOTD) banner  for the switch

SW1(config)#banner motd $
Enter TEXT message.  End with the character '$'.
*************************************************

Only Authorized Users Allowed

*************************************************
$

SW1(config)#^Z
SW1#exit

*************************************************

Only Authorized Users Allowed

*************************************************


SW1>

3)  Configure a line console password - India@123 l

ine vty - cisco

enable secret password - Cisco@123

SW1#config t
SW1(config)#line console 0
SW1(config-line)#password India@123
SW1(config-line)#login
SW1(config)#enable secret Cisco@123
SW1(config)#exit
SW1#

*************************************************

Only Authorized Users Allowed

*************************************************


User Access Verification

Password:

SW1>en
Password:
SW1#


Thanks for reading 

amartechstuff

Sunday 6 December 2020

SPAN - PORT MIRRORING - CONFIGURATION ON CISCO PACKET TRACER

 SPAN - Switched Port Analyzer 

Allows you to monitor and capture network traffic 😊

Traffic is flowing from source (client) to destination (server)

and we need to monitor and capture the same on the monitoring device -sniffer


 

Once we enable span the initiate the traffic from client to server - a copy of traffic is sent on the switchport connected to sniffer.

Switch(config)#monitor session 1 source interface fa0/1
Switch(config)#monitor session 1 destination interface fa0/3
Switch#sh monitor
Session 1
---------
Type                   : Local Session
Description            : -
Source Ports           :
    Both               : Fa0/1
Destination Ports      : Fa0/3
    Encapsulation      : Native
          Ingress      : Disabled



THANKS FOR READING

AMARTECHSTUFF

Tuesday 1 December 2020

BGP LAB DAY 4

 


 R1#sh ip bgp summary
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 41, main routing table version 41
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
6/5 BGP path/bestpath attribute entries using 816 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6032 total bytes of memory
BGP activity 28/8 prefixes, 44/16 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200      21      20       41    0    0 00:09:18       16
13.1.1.3        4          300     121     126       41    0    0 01:46:18        8
R1#
R1#
R1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        unassigned      YES NVRAM  administratively down down
FastEthernet1/0        unassigned      YES NVRAM  administratively down down
Ethernet2/0            12.1.1.1        YES NVRAM  up                    up
Ethernet2/1            13.1.1.1        YES NVRAM  up                    up
Ethernet2/2            21.1.1.1        YES NVRAM  up                    up
Ethernet2/3            unassigned      YES NVRAM  administratively down down
Loopback0              1.1.1.1         YES NVRAM  up                    up
Loopback1              10.1.1.1        YES NVRAM  up                    up
Loopback2              10.1.2.1        YES NVRAM  up                    up
Loopback3              10.1.3.1        YES NVRAM  up                    up
Loopback4              10.1.4.1        YES NVRAM  up                    up

!! Changing Router id to 1.1.1.1

R1#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#
R1(config)#router bgp 100
R1(config-router)#bgp router-id ?
  A.B.C.D  Manually configured router identifier
  vrf      vrf-specific router id configuration

R1(config-router)#bgp router-id 1.1.1.1
R1(config-router)#
*Nov 30 09:46:58.451: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Down Router ID changed
*Nov 30 09:46:58.451: %BGP_SESSION-5-ADJCHANGE: neighbor 2.2.2.2 IPv4 Unicast topology base removed from session  Router ID changed
*Nov 30 09:46:58.459: %BGP-5-ADJCHANGE: neighbor 13.1.1.3 Down Router ID changed
*Nov 30 09:46:58.459: %BGP_SESSION-5-ADJCHANGE: neighbor 13.1.1.3 IPv4 Unicast topology base removed from session  Router ID changed
*Nov 30 09:46:59.335: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up
*Nov 30 09:46:59.523: %BGP-5-ADJCHANGE: neighbor 13.1.1.3 Up
R1(config-router)#^Z
R1#
R1#
R1#
R1#wr
*Nov 30 09:47:29.295: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK]
R1#sh ip bgp sum
R1#sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 21, main routing table version 21
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
6/5 BGP path/bestpath attribute entries using 816 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6032 total bytes of memory
BGP activity 48/28 prefixes, 72/44 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200      11       9       21    0    0 00:00:40       16
13.1.1.3        4          300       6       9       21    0    0 00:00:40        8

Monday 30 November 2020

BGP MASTER LAB



BGP LAB DAY 1

https://networkengineerstuff.blogspot.com/2020/10/bgp-lab-day-1.html

 BGP LAB DAY 2

https://networkengineerstuff.blogspot.com/2020/10/bgp-lab-day-2.html

BGP LAB DAY 3

https://networkengineerstuff.blogspot.com/2020/11/bgp-lab-day-3.html

 BGP LAB DAY4

https://networkengineerstuff.blogspot.com/2020/12/bgp-lab-day-4.html

BGP LAB DAY 3

 

Tasks

===========

Configuring Authentication for eBGP Neighborship R1 and R2

 !!Shutting & Unshutting BGP Neighborship 

 

!! Configuring Authentication for eBGP Neighborship R1 and R2
R1(config)#router bgp 100
R1(config-router)#neighbor 2.2.2.2 password ?
  <0-7>  Encryption type (0 to disable encryption, 7 for proprietary)
  LINE   The password

R1(config-router)#neighbor 2.2.2.2 password cisco@123
R1(config-router)#
R1(config-router)#^Z
!
R2(config)#
R2(config)#router bgp 200
R2(config-router)#neighbor 1.1.1.1 password cisco@123
R2(config-router)#^Z
R2#

R1#sh run | section  bgp
router bgp 100
 bgp log-neighbor-changes
 network 10.1.1.0 mask 255.255.255.0
 network 10.1.2.0 mask 255.255.255.0
 network 10.1.3.0 mask 255.255.255.0
 network 10.1.4.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 description **eBP with R2**
 neighbor 2.2.2.2 password 7 05080F1C22436E584B56 ====> the password got encrypted with type 7 password
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 soft-reconfiguration inbound
 neighbor 13.1.1.3 remote-as 300
 neighbor 13.1.1.3 description **eBP with R3**
 
 !!Shutting & Unshutting BGP Neighborship

R1#sh ip bgp summary
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 25, main routing table version 25
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
6/5 BGP path/bestpath attribute entries using 816 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6032 total bytes of memory
BGP activity 20/0 prefixes, 28/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200     103     103       25    0    0 01:27:48       16
13.1.1.3        4          300     100     102       25    0    0 01:27:30        8
R1#

R1#sh run | section bgp
router bgp 100
 bgp log-neighbor-changes
 network 10.1.1.0 mask 255.255.255.0
 network 10.1.2.0 mask 255.255.255.0
 network 10.1.3.0 mask 255.255.255.0
 network 10.1.4.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 description **eBP with R2**
 neighbor 2.2.2.2 password 7 05080F1C22436E584B56
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 soft-reconfiguration inbound
 neighbor 13.1.1.3 remote-as 300
 neighbor 13.1.1.3 description **eBGP with R3**
!
R1#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#router bgp 100
R1(config-router)# neighbor 2.2.2.2 shut
R1(config-router)# neighbor 2.2.2.2 shutdown
R1(config-router)#^Z
R1#
*Nov 30 09:30:31.851: %BGP-5-NBR_RESET: Neighbor 2.2.2.2 reset (Admin. shutdown)
*Nov 30 09:30:31.863: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Down Admin. shutdown
*Nov 30 09:30:31.863: %BGP_SESSION-5-ADJCHANGE: neighbor 2.2.2.2 IPv4 Unicast topology base removed from session  Admin. shutdown
*Nov 30 09:30:33.007: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#sh ip bgp sum
R1#sh ip bgp summary
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 33, main routing table version 33
12 network entries using 1728 bytes of memory
12 path entries using 960 bytes of memory
6/3 BGP path/bestpath attribute entries using 816 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3600 total bytes of memory
BGP activity 20/0 prefixes, 28/16 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200       0       0        1    0    0 00:00:10 Idle (Admin)
13.1.1.3        4          300     106     109       33    0    0 01:32:38        8
R1#

On R1 the state will be Idle (Admin) whereas on R2 it will be Idle .

R2#
*Nov 30 09:30:32.155: %BGP-5-NBR_RESET: Neighbor 1.1.1.1 reset (Peer closed the session)
*Nov 30 09:30:32.171: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Down Peer closed the session
*Nov 30 09:30:32.171: %BGP_SESSION-5-ADJCHANGE: neighbor 1.1.1.1 IPv4 Unicast topology base removed from session  Peer closed the session
R2#
R2#
R2#
R2#
R2#sh ip bgp sum
R2#sh ip bgp summary
BGP router identifier 20.1.4.1, local AS number 200
BGP table version is 25, main routing table version 25
16 network entries using 2304 bytes of memory
16 path entries using 1280 bytes of memory
4/4 BGP path/bestpath attribute entries using 544 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4176 total bytes of memory
BGP activity 20/4 prefixes, 28/12 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4          100       0       0        1    0    0 00:02:22 Idle
24.1.1.4        4          300     112     118       25    0    0 01:34:28       12
R2#


!!Unshut the BGP Neighborship
R1#   sh run | section bgp
router bgp 100
 bgp log-neighbor-changes
 network 10.1.1.0 mask 255.255.255.0
 network 10.1.2.0 mask 255.255.255.0
 network 10.1.3.0 mask 255.255.255.0
 network 10.1.4.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 description **eBP with R2**
 neighbor 2.2.2.2 password 7 05080F1C22436E584B56
 neighbor 2.2.2.2 shutdown
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 soft-reconfiguration inbound
 neighbor 13.1.1.3 remote-as 300
 neighbor 13.1.1.3 description **eBGP with R3**
R1#
R1#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 100
R1(config-router)#no neighbor 2.2.2.2 shutdown
R1(config-router)#^Z
R1#
*Nov 30 09:35:03.887: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up
*Nov 30 09:35:04.071: %SYS-5-CONFIG_I: Configured from console by console

R1#sh ip bgp summary
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 41, main routing table version 41
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
6/5 BGP path/bestpath attribute entries using 816 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6032 total bytes of memory
BGP activity 28/8 prefixes, 44/16 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200      11      11       41    0    0 00:00:12       16
13.1.1.3        4          300     111     116       41    0    0 01:37:12        8


Thanks for reading 

amartechstuff

Friday 27 November 2020

Generic Routing Encapsulation (GRE) Tunnel Configuration in Cisco Packet Tracer (LAB)

 


PART 1 - Configure Basic Stuff
============================================================================

Step 1:- Create the topology as shown in the diagram in Packet Tracer.

Step 2:- Configure Hostname and IP addresses Routers, Switches and PCs as shown in the diagram.

Step 3:- On Pune Router & Chennai Router configure default route pointing towards ISP.



PART 2 -Configure GRE Tunnel Between Pune Router & Chennai Router
==============================================================================

Step 1:-Configure GRE Tunnel interfaces on Pune Router & Chennai Router as shown in the diagram
        keeping source as WAN interfaces

Step 2:-Verify the status of the GRE Tunnel 0 , Tunnel Protocol , Tunnel source & destination.

Step 3:-Ping accross tunnel from both routers.

Step 4:-Traceroute to determine the path to the tunnel. =====> one hop !!!!!

PART 3 - Configure Routing over GRE Tunnel

===============================================================================

Step 1:- Configure EIGRP AS 100 on Pune Router & Chennai Router and advertise the tunnel , LAN networks.

Step 2:-Verify EIGRP Neighborship.

Step 3:-Verify the routing table.

Step 4:-Check end to end connectivity by ping PC1 to PC2 and vice versa.



Monday 2 November 2020

Cisco Nexus Models Overview

  In this blog we will focus on Cisco Nexus Switches Models

+ Cisco Nexus Switches were introduced by Cisco in Jan 2008

+ These are DATA Center Switches

+ NX-OS is the operating system which runs on these switches which is quite different from the catalyst IOS .

+ There are various models in Cisco Nexus Switches which are deployed in Data Center as per requirement .

+ Gives you option of Modular and Fixed Switches .


1) Cisco Nexus 9000 Series

 




+ These can operate in ACI (Application Centric Infrastructure) mode which no other switches can operate .

+ Gives you option of Modular and Fixed Switches .

+ Supports VXLAN

https://www.cisco.com/c/en_in/products/switches/nexus-9000-series-switches/models-comparison.html

2) Cisco Nexus 7000 Series


 


+ Modular Switches

+ Supports DCI Technologies - OTV & LISP

+ Also supports VDC ,FCOE

https://www.cisco.com/c/en/us/products/switches/nexus-7000-series-switches/models-comparison.html

+ Nexus 7018 can provide Switching capacity upto 17.6 Tbps.

+ Nexus 7718 can provide Switching capacity upto 90 Tbps.

3) Cisco Nexus 5000 Series


 


+ Fixed Switches

+ Data Center Access Layer Switches (End of Row)

https://www.cisco.com/c/en/us/products/switches/nexus-5000-series-switches/models-comparison.html

+ 10G platform switch Nexus 5672UP can provide Switching capacity upto 2.56 Tbps.

+ 40G platform switch Nexus 5624Q can provide Switching capacity upto 7.68 Tbps.

+ Supports VXLAN and FCOE

4) Cisco Nexus 3000 Series


 


+ Fixed Switches

+ The 3000 Series offers low-latency, highly programmable, high-density switches.

+ These compact fixed switches are excellent for general-purpose deployments, high-performance computing (HPC),  high-frequency trading (HFT), massively scalable data center (MSDC), and cloud networks.

https://www.cisco.com/c/en/us/products/switches/nexus-3000-series-switches/models-comparison.html#~tab-nexus3600

+ Nexus 3000 can provide Switching capacity upto 176 Gbps.

+ Nexus 3600 can provide Switching capacity upto 7.2 Tbps.

5) Cisco Nexus 2000 Series


 


+  Fabric Extenders (FEX)

+  They appear as an extension to the parent switch to which they connect.

+Parent switch support spans Cisco Nexus 5000, 6000, 7000, and 9000 Series Switches and Cisco UCS fabric interconnects.

https://www.cisco.com/c/en/us/products/switches/nexus-2000-series-fabric-extenders/models-comparison.html

6) Cisco Nexus 6000 Series

+ End of Sale
 

https://www.cisco.com/c/en/us/products/switches/nexus-6000-series-switches/index.html

7) Cisco Nexus 1000v Series

https://www.cisco.com/c/en/us/products/switches/nexus-1000v-switch-vmware-vsphere/index.html

+ The 1000v is a virtual switch for use in virtual environments including both VMware vSphere and Microsoft Hyper-V[2]
+ It is as such not a physical box but a software application that interacts with the hypervisor so you can virtualize the networking environment and be able to configure your system as if all virtual servers have connections to a physical switch and include the capabilities thata switch offers such as multiple VLANs per virtual interface, layer-3 options, security features etc.


Wednesday 28 October 2020

BGP INTERVIEW QUESTIONS & ANSWERS

 


 

Question 1 - Tell us something about BGP ?

Answer -

    Biggest Routing Protocol
    Most Complex Routing Protocol
    Need to have lot of Patience
    Can’t compare with IGPs – RIP ,EIGRP,OSPF etc.
    BGP – FLOW CONTROL
    Route Manipulation
    Can Handle Huge Routing Table
    A.K.A ROUTING PROTOCOL OF INTERNET
    Exterior Gateway Protocol (EGP) – Runs between Autonomous System
    Uses TCP Port 179


Question 2 -What is an Autonomous System ?


Answer -

An Autonomous System (AS) is a group of networks under a single administrative control.
An AS can be Internet Service Provider (ISP) or a large Enterprise Organization.

Each AS will have an ASN

Autonomous System Number (ASN) - 16 bit binary number & we can represent (2 16) numbers, which is equal to 65536 in decimals.
Range of ASN – 0 to 65535
0 , 65535 - Reserved
1 – 64511 - Internet Routing – ISP AS
64512 – 65534 Private Use - Private AS

Question 3 - What is the difference between iBGP & eBGP ?

Answer -


eBGP -  External Border Gateway Protocol

It runs between two BGP routers in different autonomous system.

iBGP -  Internal Border Gateway Protocol

It runs between two BGP routers in the same autonomous system

The AD Values
EBGP = 20
IBGP = 200

Question 4 - Why BGP is known as SLOWEST Routing Protocol ?

Answer-


Convergence is Very Slow

Timers – Hello – 60 Secs and Dead – 180 Secs

Question 5 -What is BGP Router Identifier (BGP RID) ?

Answer -


It is the highest loopback IP address and in absence of loopback interface/s it will be the highest IP address of an active physical interface.

BGP Router must have BGP RID to establish BGP Peer session.

BGP router id can be also manually configured using bgp router-id command .

But once it is configured the bgp session will be reset.

Question 6 - What are Keepalive Messages in BGP ?

Answer -


Once the BGP Neighorship is up and running ,these Keepalive messages are send continuously between BGP Speaker in a
specific interval which is known as Keepalive Interval or Keepalive Time.

Keepalive messages are send between BGP Speakers to verify whether peering BGP Neighbor is live or not .

By default Keepalive Time is 60 Seconds.

Question 7 - How to make a BGP Router member of two Autonomous Systems ?

Answer -


No we can't make it !

Only one BGP AS can be configured on the device.

Hence BGP Router can be member of only one Autonomous System .


Question 8 -What is " BGP SYNCHRONIZATION RULE "

Answer -


 "Don't use or advertise the route/s learned via an iBGP neighbor to an eBGP neighbor unless &
until the same is/are learned via some other IGP like RIP , OSPF ,EIGRP etc . "


This feature is off by default in Cisco IOS Software release 12.2(8)T and later.

To disable BGP Synchronization

R1(config)#router bgp 100                    -------> AS is 100
R1(config-router)#no synchronization

To enable BGP Synchronization

R1(config-router)#synchronization

Question 9 - On a BGP Router how can we check the list of BGP Neighbor/s and the routes received and advertised from/to a particular neighbor ?

Answer -


sh ip bgp summary
sh ip bgp neigbhor x.x.x.x received-routes
sh ip bgp neighbor x.x.x.x adverstied routes

Question 10 - Tell us something about BGP Attributes ?

Answer -

As we are aware that each routing protocol uses some metric for path selection
e.g. RIP uses Hop count , EIGPR uses a composite metric which includes Bandwidth and Delay (by default) ,
OSPF uses Cost i.e Bandwith to calculate the best route.

Similarly BGP also uses something known as "Attributes" to the find the best route to reach a destination.

 There are 4 categories of BGP Attributes :-

1) Well Known Mandatory -  

    Supported (Known/Understand) by all BGP Routers
    Must be present in BGP Update Message.
    AS Path, Origin ,Next Hop.


2) Well Known Discretionary -

    Supported (Known/Understand) by all BGP Routers.
    May or May not be present in BGP Update Message.
    Local Preference


3) Optional Transitive -

    May or May not be supported  a BGP Routers.
    Passed on the other BGP Routers.
    Aggregator , Community.

4) Optional Non-Transitive-

    May or May not be supported by a BGP Routers.
    If not supported may ignore the update and may not pass on to the other BGP Routers.
    MED ,Router Cluster list , Router Originator List.

Thanks for Reading 

amartechstuff




Wednesday 14 October 2020

BGP LAB - DAY 2

 

Task

=========

BGP Peering Configuration

 

BGP Peering Configuration
=============================
R1
config t
router bgp 100
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 update-source loopback 0
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 description **eBP with R2**
!
neighbor 13.1.1.3 remote-as 300
neighbor 13.1.1.3 description **eBP with R3**
!
network 10.1.1.0 mask 255.255.255.0
network 10.1.2.0 mask 255.255.255.0
network 10.1.3.0 mask 255.255.255.0
network 10.1.4.0 mask 255.255.255.0
!

R2
config t
router bgp 200
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source loopback 0
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 description **eBP with R1**
!
neighbor 24.1.1.4 remote-as 300
neighbor 24.1.1.4 description **eBP with R4**
!
network 20.1.1.0 mask 255.255.255.0
network 20.1.2.0 mask 255.255.255.0
network 20.1.3.0 mask 255.255.255.0
network 20.1.4.0 mask 255.255.255.0
!


R3
config t
router bgp 300
neighbor 13.1.1.1 remote-as 100
neighbor 13.1.1.1 description **eBGP with R1**
!
neighbor 4.4.4.4 remote-as 300
neighbor 4.4.4.4 description **iBP with R4**
neighbor 4.4.4.4 update-source loopback 0
!
network 30.1.1.0 mask 255.255.255.0
network 30.1.2.0 mask 255.255.255.0
network 30.1.3.0 mask 255.255.255.0
network 30.1.4.0 mask 255.255.255.0
!

R4
config t
router bgp 300
neighbor 24.1.1.2 remote-as 200
neighbor 24.1.1.2 description **eBGP with R2**
!
neighbor 46.1.1.6 remote-as 600
neighbor 46.1.1.6 description **eBGP with R6**
!
neighbor 4.4.4.4 remote-as 300
neighbor 4.4.4.4 description **iBGP with R4**
neighbor 4.4.4.4 update-source loopback 0
!
network 40.1.1.0 mask 255.255.255.0
network 40.1.2.0 mask 255.255.255.0
network 40.1.3.0 mask 255.255.255.0
network 40.1.4.0 mask 255.255.255.0
!

R6
config t
router bgp 600
neighbor 46.1.1.4 remote-as 300
neighbor 46.1.1.4 description **eBGP with R4**
!
network 60.1.1.0 mask 255.255.255.0
network 60.1.2.0 mask 255.255.255.0
network 60.1.3.0 mask 255.255.255.0
network 60.1.4.0 mask 255.255.255.0
!
=================================================================================

OUTPUT

R1#sh ip bgp sum
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 21, main routing table version 21
20 network entries using 2880 bytes of memory
20 path entries using 1600 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5256 total bytes of memory
BGP activity 20/0 prefixes, 24/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200      35      36       21    0    0 00:26:38       12
13.1.1.3        4          300      25      31       21    0    0 00:20:01        4
R1#
R1#
R1#sh ip bgp
BGP table version is 21, local router ID is 10.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
 *>  10.1.2.0/24      0.0.0.0                  0         32768 i
 *>  10.1.3.0/24      0.0.0.0                  0         32768 i
 *>  10.1.4.0/24      0.0.0.0                  0         32768 i
 *>  20.1.1.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.2.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.3.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.4.0/24      2.2.2.2                  0             0 200 i
 *>  30.1.1.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.2.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.3.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.4.0/24      13.1.1.3                 0             0 300 i
 *>  40.1.1.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.2.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.3.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.4.0/24      2.2.2.2                                0 200 300 i
 *>  60.1.1.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.2.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.3.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.4.0/24      2.2.2.2                                0 200 300 600 i
R1#

R2#sh ip bgp summary
BGP router identifier 20.1.4.1, local AS number 200
BGP table version is 29, main routing table version 29
20 network entries using 2880 bytes of memory
20 path entries using 1600 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5256 total bytes of memory
BGP activity 20/0 prefixes, 24/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4          100      37      36       29    0    0 00:27:41        8
24.1.1.4        4          300      24      27       29    0    0 00:14:45        8
R2#
R2#
R2#sh ip bgp
BGP table version is 29, local router ID is 20.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.2.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.3.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.4.0/24      1.1.1.1                  0             0 100 i
 *>  20.1.1.0/24      0.0.0.0                  0         32768 i
 *>  20.1.2.0/24      0.0.0.0                  0         32768 i
 *>  20.1.3.0/24      0.0.0.0                  0         32768 i
 *>  20.1.4.0/24      0.0.0.0                  0         32768 i
 *>  30.1.1.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.2.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.3.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.4.0/24      1.1.1.1                                0 100 300 i
 *>  40.1.1.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.2.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.3.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.4.0/24      24.1.1.4                 0             0 300 i
 *>  60.1.1.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.2.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.3.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.4.0/24      24.1.1.4                               0 300 600 i
R2#

R3#sh ip bgp summary
BGP router identifier 30.1.4.1, local AS number 300
BGP table version is 17, main routing table version 17
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
7/4 BGP path/bestpath attribute entries using 952 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6192 total bytes of memory
BGP activity 20/0 prefixes, 28/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4          300      24      24       17    0    0 00:16:06       16
13.1.1.1        4          100      25      22       17    0    0 00:16:21        8

R3#
R3#sh ip bgp
BGP table version is 17, local router ID is 30.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 10.1.1.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.2.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.3.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.4.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 *>  20.1.1.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.2.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.3.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.4.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  30.1.1.0/24      0.0.0.0                  0         32768 i
 *>  30.1.2.0/24      0.0.0.0                  0         32768 i
 *>  30.1.3.0/24      0.0.0.0                  0         32768 i
 *>  30.1.4.0/24      0.0.0.0                  0         32768 i
 r>i 40.1.1.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.2.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.3.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.4.0/24      4.4.4.4                  0    100      0 i
 * i 60.1.1.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.2.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.3.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.4.0/24      46.1.1.6                 0    100      0 600 i
R3#


R4#sh ip bgp summary
BGP router identifier 40.1.4.1, local AS number 300
BGP table version is 25, main routing table version 25
16 network entries using 2304 bytes of memory
16 path entries using 1280 bytes of memory
4/4 BGP path/bestpath attribute entries using 544 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4200 total bytes of memory
BGP activity 20/4 prefixes, 20/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
24.1.1.2        4          200      29      26       25    0    0 00:16:56        8
46.1.1.6        4          600      23      26       25    0    0 00:16:54        4
R4#
R4#
R4#sh ip bgp
BGP table version is 21, local router ID is 40.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.2.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.3.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.4.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 * i 20.1.1.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.2.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.3.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.4.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 r>i 30.1.1.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.2.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.3.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.4.0/24      3.3.3.3                  0    100      0 i
 *>  40.1.1.0/24      0.0.0.0                  0         32768 i
 *>  40.1.2.0/24      0.0.0.0                  0         32768 i
 *>  40.1.3.0/24      0.0.0.0                  0         32768 i
 *>  40.1.4.0/24      0.0.0.0                  0         32768 i
 *>  60.1.1.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.2.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.3.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.4.0/24      46.1.1.6                 0             0 600 i
R4#

R5#sh ip bgp summary
% BGP not active

R6#sh ip  bgp summary
BGP router identifier 60.1.4.1, local AS number 600
BGP table version is 33, main routing table version 33
16 network entries using 2304 bytes of memory
16 path entries using 1280 bytes of memory
4/4 BGP path/bestpath attribute entries using 544 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4200 total bytes of memory
BGP activity 24/8 prefixes, 24/8 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
46.1.1.4        4          300      27      24       33    0    0 00:17:59       12
R6#
R6#sh ip bgp
BGP table version is 33, local router ID is 60.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.2.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.3.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.4.0/24      46.1.1.4                               0 300 200 100 i
 *>  20.1.1.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.2.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.3.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.4.0/24      46.1.1.4                               0 300 200 i
 *>  40.1.1.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.2.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.3.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.4.0/24      46.1.1.4                 0             0 300 i
 *>  60.1.1.0/24      0.0.0.0                  0         32768 i
 *>  60.1.2.0/24      0.0.0.0                  0         32768 i
 *>  60.1.3.0/24      0.0.0.0                  0         32768 i
 *>  60.1.4.0/24      0.0.0.0                  0         32768 i
R6#



Thanks for Reading 

amartechstuff