Wednesday 28 October 2020

BGP INTERVIEW QUESTIONS & ANSWERS

 


 

Question 1 - Tell us something about BGP ?

Answer -

    Biggest Routing Protocol
    Most Complex Routing Protocol
    Need to have lot of Patience
    Can’t compare with IGPs – RIP ,EIGRP,OSPF etc.
    BGP – FLOW CONTROL
    Route Manipulation
    Can Handle Huge Routing Table
    A.K.A ROUTING PROTOCOL OF INTERNET
    Exterior Gateway Protocol (EGP) – Runs between Autonomous System
    Uses TCP Port 179


Question 2 -What is an Autonomous System ?


Answer -

An Autonomous System (AS) is a group of networks under a single administrative control.
An AS can be Internet Service Provider (ISP) or a large Enterprise Organization.

Each AS will have an ASN

Autonomous System Number (ASN) - 16 bit binary number & we can represent (2 16) numbers, which is equal to 65536 in decimals.
Range of ASN – 0 to 65535
0 , 65535 - Reserved
1 – 64511 - Internet Routing – ISP AS
64512 – 65534 Private Use - Private AS

Question 3 - What is the difference between iBGP & eBGP ?

Answer -


eBGP -  External Border Gateway Protocol

It runs between two BGP routers in different autonomous system.

iBGP -  Internal Border Gateway Protocol

It runs between two BGP routers in the same autonomous system

The AD Values
EBGP = 20
IBGP = 200

Question 4 - Why BGP is known as SLOWEST Routing Protocol ?

Answer-


Convergence is Very Slow

Timers – Hello – 60 Secs and Dead – 180 Secs

Question 5 -What is BGP Router Identifier (BGP RID) ?

Answer -


It is the highest loopback IP address and in absence of loopback interface/s it will be the highest IP address of an active physical interface.

BGP Router must have BGP RID to establish BGP Peer session.

BGP router id can be also manually configured using bgp router-id command .

But once it is configured the bgp session will be reset.

Question 6 - What are Keepalive Messages in BGP ?

Answer -


Once the BGP Neighorship is up and running ,these Keepalive messages are send continuously between BGP Speaker in a
specific interval which is known as Keepalive Interval or Keepalive Time.

Keepalive messages are send between BGP Speakers to verify whether peering BGP Neighbor is live or not .

By default Keepalive Time is 60 Seconds.

Question 7 - How to make a BGP Router member of two Autonomous Systems ?

Answer -


No we can't make it !

Only one BGP AS can be configured on the device.

Hence BGP Router can be member of only one Autonomous System .


Question 8 -What is " BGP SYNCHRONIZATION RULE "

Answer -


 "Don't use or advertise the route/s learned via an iBGP neighbor to an eBGP neighbor unless &
until the same is/are learned via some other IGP like RIP , OSPF ,EIGRP etc . "


This feature is off by default in Cisco IOS Software release 12.2(8)T and later.

To disable BGP Synchronization

R1(config)#router bgp 100                    -------> AS is 100
R1(config-router)#no synchronization

To enable BGP Synchronization

R1(config-router)#synchronization

Question 9 - On a BGP Router how can we check the list of BGP Neighbor/s and the routes received and advertised from/to a particular neighbor ?

Answer -


sh ip bgp summary
sh ip bgp neigbhor x.x.x.x received-routes
sh ip bgp neighbor x.x.x.x adverstied routes

Question 10 - Tell us something about BGP Attributes ?

Answer -

As we are aware that each routing protocol uses some metric for path selection
e.g. RIP uses Hop count , EIGPR uses a composite metric which includes Bandwidth and Delay (by default) ,
OSPF uses Cost i.e Bandwith to calculate the best route.

Similarly BGP also uses something known as "Attributes" to the find the best route to reach a destination.

 There are 4 categories of BGP Attributes :-

1) Well Known Mandatory -  

    Supported (Known/Understand) by all BGP Routers
    Must be present in BGP Update Message.
    AS Path, Origin ,Next Hop.


2) Well Known Discretionary -

    Supported (Known/Understand) by all BGP Routers.
    May or May not be present in BGP Update Message.
    Local Preference


3) Optional Transitive -

    May or May not be supported  a BGP Routers.
    Passed on the other BGP Routers.
    Aggregator , Community.

4) Optional Non-Transitive-

    May or May not be supported by a BGP Routers.
    If not supported may ignore the update and may not pass on to the other BGP Routers.
    MED ,Router Cluster list , Router Originator List.

Thanks for Reading 

amartechstuff




Wednesday 14 October 2020

BGP LAB - DAY 2

 

Task

=========

BGP Peering Configuration

 

BGP Peering Configuration
=============================
R1
config t
router bgp 100
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 update-source loopback 0
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 description **eBP with R2**
!
neighbor 13.1.1.3 remote-as 300
neighbor 13.1.1.3 description **eBP with R3**
!
network 10.1.1.0 mask 255.255.255.0
network 10.1.2.0 mask 255.255.255.0
network 10.1.3.0 mask 255.255.255.0
network 10.1.4.0 mask 255.255.255.0
!

R2
config t
router bgp 200
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source loopback 0
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 description **eBP with R1**
!
neighbor 24.1.1.4 remote-as 300
neighbor 24.1.1.4 description **eBP with R4**
!
network 20.1.1.0 mask 255.255.255.0
network 20.1.2.0 mask 255.255.255.0
network 20.1.3.0 mask 255.255.255.0
network 20.1.4.0 mask 255.255.255.0
!


R3
config t
router bgp 300
neighbor 13.1.1.1 remote-as 100
neighbor 13.1.1.1 description **eBGP with R1**
!
neighbor 4.4.4.4 remote-as 300
neighbor 4.4.4.4 description **iBP with R4**
neighbor 4.4.4.4 update-source loopback 0
!
network 30.1.1.0 mask 255.255.255.0
network 30.1.2.0 mask 255.255.255.0
network 30.1.3.0 mask 255.255.255.0
network 30.1.4.0 mask 255.255.255.0
!

R4
config t
router bgp 300
neighbor 24.1.1.2 remote-as 200
neighbor 24.1.1.2 description **eBGP with R2**
!
neighbor 46.1.1.6 remote-as 600
neighbor 46.1.1.6 description **eBGP with R6**
!
neighbor 4.4.4.4 remote-as 300
neighbor 4.4.4.4 description **iBGP with R4**
neighbor 4.4.4.4 update-source loopback 0
!
network 40.1.1.0 mask 255.255.255.0
network 40.1.2.0 mask 255.255.255.0
network 40.1.3.0 mask 255.255.255.0
network 40.1.4.0 mask 255.255.255.0
!

R6
config t
router bgp 600
neighbor 46.1.1.4 remote-as 300
neighbor 46.1.1.4 description **eBGP with R4**
!
network 60.1.1.0 mask 255.255.255.0
network 60.1.2.0 mask 255.255.255.0
network 60.1.3.0 mask 255.255.255.0
network 60.1.4.0 mask 255.255.255.0
!
=================================================================================

OUTPUT

R1#sh ip bgp sum
BGP router identifier 10.1.4.1, local AS number 100
BGP table version is 21, main routing table version 21
20 network entries using 2880 bytes of memory
20 path entries using 1600 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5256 total bytes of memory
BGP activity 20/0 prefixes, 24/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          200      35      36       21    0    0 00:26:38       12
13.1.1.3        4          300      25      31       21    0    0 00:20:01        4
R1#
R1#
R1#sh ip bgp
BGP table version is 21, local router ID is 10.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
 *>  10.1.2.0/24      0.0.0.0                  0         32768 i
 *>  10.1.3.0/24      0.0.0.0                  0         32768 i
 *>  10.1.4.0/24      0.0.0.0                  0         32768 i
 *>  20.1.1.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.2.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.3.0/24      2.2.2.2                  0             0 200 i
 *>  20.1.4.0/24      2.2.2.2                  0             0 200 i
 *>  30.1.1.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.2.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.3.0/24      13.1.1.3                 0             0 300 i
 *>  30.1.4.0/24      13.1.1.3                 0             0 300 i
 *>  40.1.1.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.2.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.3.0/24      2.2.2.2                                0 200 300 i
 *>  40.1.4.0/24      2.2.2.2                                0 200 300 i
 *>  60.1.1.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.2.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.3.0/24      2.2.2.2                                0 200 300 600 i
 *>  60.1.4.0/24      2.2.2.2                                0 200 300 600 i
R1#

R2#sh ip bgp summary
BGP router identifier 20.1.4.1, local AS number 200
BGP table version is 29, main routing table version 29
20 network entries using 2880 bytes of memory
20 path entries using 1600 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5256 total bytes of memory
BGP activity 20/0 prefixes, 24/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4          100      37      36       29    0    0 00:27:41        8
24.1.1.4        4          300      24      27       29    0    0 00:14:45        8
R2#
R2#
R2#sh ip bgp
BGP table version is 29, local router ID is 20.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.2.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.3.0/24      1.1.1.1                  0             0 100 i
 *>  10.1.4.0/24      1.1.1.1                  0             0 100 i
 *>  20.1.1.0/24      0.0.0.0                  0         32768 i
 *>  20.1.2.0/24      0.0.0.0                  0         32768 i
 *>  20.1.3.0/24      0.0.0.0                  0         32768 i
 *>  20.1.4.0/24      0.0.0.0                  0         32768 i
 *>  30.1.1.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.2.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.3.0/24      1.1.1.1                                0 100 300 i
 *>  30.1.4.0/24      1.1.1.1                                0 100 300 i
 *>  40.1.1.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.2.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.3.0/24      24.1.1.4                 0             0 300 i
 *>  40.1.4.0/24      24.1.1.4                 0             0 300 i
 *>  60.1.1.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.2.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.3.0/24      24.1.1.4                               0 300 600 i
 *>  60.1.4.0/24      24.1.1.4                               0 300 600 i
R2#

R3#sh ip bgp summary
BGP router identifier 30.1.4.1, local AS number 300
BGP table version is 17, main routing table version 17
20 network entries using 2880 bytes of memory
28 path entries using 2240 bytes of memory
7/4 BGP path/bestpath attribute entries using 952 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 6192 total bytes of memory
BGP activity 20/0 prefixes, 28/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4          300      24      24       17    0    0 00:16:06       16
13.1.1.1        4          100      25      22       17    0    0 00:16:21        8

R3#
R3#sh ip bgp
BGP table version is 17, local router ID is 30.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 10.1.1.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.2.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.3.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 * i 10.1.4.0/24      24.1.1.2                 0    100      0 200 100 i
 *>                   13.1.1.1                 0             0 100 i
 *>  20.1.1.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.2.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.3.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  20.1.4.0/24      13.1.1.1                               0 100 200 i
 * i                  24.1.1.2                 0    100      0 200 i
 *>  30.1.1.0/24      0.0.0.0                  0         32768 i
 *>  30.1.2.0/24      0.0.0.0                  0         32768 i
 *>  30.1.3.0/24      0.0.0.0                  0         32768 i
 *>  30.1.4.0/24      0.0.0.0                  0         32768 i
 r>i 40.1.1.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.2.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.3.0/24      4.4.4.4                  0    100      0 i
 r>i 40.1.4.0/24      4.4.4.4                  0    100      0 i
 * i 60.1.1.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.2.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.3.0/24      46.1.1.6                 0    100      0 600 i
 * i 60.1.4.0/24      46.1.1.6                 0    100      0 600 i
R3#


R4#sh ip bgp summary
BGP router identifier 40.1.4.1, local AS number 300
BGP table version is 25, main routing table version 25
16 network entries using 2304 bytes of memory
16 path entries using 1280 bytes of memory
4/4 BGP path/bestpath attribute entries using 544 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4200 total bytes of memory
BGP activity 20/4 prefixes, 20/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
24.1.1.2        4          200      29      26       25    0    0 00:16:56        8
46.1.1.6        4          600      23      26       25    0    0 00:16:54        4
R4#
R4#
R4#sh ip bgp
BGP table version is 21, local router ID is 40.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.2.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.3.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 *>  10.1.4.0/24      24.1.1.2                               0 200 100 i
 * i                  13.1.1.1                 0    100      0 100 i
 * i 20.1.1.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.2.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.3.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 * i 20.1.4.0/24      13.1.1.1                 0    100      0 100 200 i
 *>                   24.1.1.2                 0             0 200 i
 r>i 30.1.1.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.2.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.3.0/24      3.3.3.3                  0    100      0 i
 r>i 30.1.4.0/24      3.3.3.3                  0    100      0 i
 *>  40.1.1.0/24      0.0.0.0                  0         32768 i
 *>  40.1.2.0/24      0.0.0.0                  0         32768 i
 *>  40.1.3.0/24      0.0.0.0                  0         32768 i
 *>  40.1.4.0/24      0.0.0.0                  0         32768 i
 *>  60.1.1.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.2.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.3.0/24      46.1.1.6                 0             0 600 i
 *>  60.1.4.0/24      46.1.1.6                 0             0 600 i
R4#

R5#sh ip bgp summary
% BGP not active

R6#sh ip  bgp summary
BGP router identifier 60.1.4.1, local AS number 600
BGP table version is 33, main routing table version 33
16 network entries using 2304 bytes of memory
16 path entries using 1280 bytes of memory
4/4 BGP path/bestpath attribute entries using 544 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4200 total bytes of memory
BGP activity 24/8 prefixes, 24/8 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
46.1.1.4        4          300      27      24       33    0    0 00:17:59       12
R6#
R6#sh ip bgp
BGP table version is 33, local router ID is 60.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.1.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.2.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.3.0/24      46.1.1.4                               0 300 200 100 i
 *>  10.1.4.0/24      46.1.1.4                               0 300 200 100 i
 *>  20.1.1.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.2.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.3.0/24      46.1.1.4                               0 300 200 i
 *>  20.1.4.0/24      46.1.1.4                               0 300 200 i
 *>  40.1.1.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.2.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.3.0/24      46.1.1.4                 0             0 300 i
 *>  40.1.4.0/24      46.1.1.4                 0             0 300 i
 *>  60.1.1.0/24      0.0.0.0                  0         32768 i
 *>  60.1.2.0/24      0.0.0.0                  0         32768 i
 *>  60.1.3.0/24      0.0.0.0                  0         32768 i
 *>  60.1.4.0/24      0.0.0.0                  0         32768 i
R6#



Thanks for Reading 

amartechstuff

Tuesday 13 October 2020

BGP LAB - DAY 1


 Tasks:-

----------------

Interface level Configuration & Required IGP Configuration

 

Interface Configurations 

=======================


Interface level Configuration & Required IGP Configuration
=============================================

R1
============
config t
hostname R1
int e2/0
description **Connection to R2**
no shut
ip address 12.1.1.1 255.255.255.0
!
int e2/2
description **Connection to R2**
no shut
ip address 21.1.1.1 255.255.255.0
!
int e2/1
description **Connection to R3**
no shut
ip address 13.1.1.1 255.255.255.0
!
int loopback 0
ip address 1.1.1.1 255.255.255.255
!
int loopback 1
ip address 10.1.1.1 255.255.255.0
!
int loopback 2
ip address 10.1.2.1 255.255.255.0
!
int loopback 3
ip address 10.1.3.1 255.255.255.0
!
int loopback 4
ip address 10.1.4.1 255.255.255.0
!

======================================================================

Interface level Configuration
=================================
R2
============
config
hostname R2
int e2/0
description **Connection to R1**
no shut
ip address 12.1.1.2 255.255.255.0
!
int e2/2
description **Connection to R1**
no shut
ip address 21.1.1.2 255.255.255.0
!
int e2/1
description **Connection to R4**
no shut
ip address 24.1.1.2 255.255.255.0
!
int loopback 0
ip address 2.2.2.2 255.255.255.255
!
int loopback 1
ip address 20.1.1.1 255.255.255.0
!
int loopback 2
ip address 20.1.2.1 255.255.255.0
!
int loopback 3
ip address 20.1.3.1 255.255.255.0
!
int loopback 4
ip address 20.1.4.1 255.255.255.0
!

Interface level Configuration
=================================
R3
============
config t
hostname R3
int e2/0
description **Connection to R1**
no shut
ip address 13.1.1.3 255.255.255.0
!
int e2/1
description **Connection to R5**
no shut
ip address 35.1.1.3 255.255.255.0
!
int loopback 0
ip address 3.3.3.3 255.255.255.255
!
int loopback 1
ip address 30.1.1.1 255.255.255.0
!
int loopback 2
ip address 30.1.2.1 255.255.255.0
!
int loopback 3
ip address 30.1.3.1 255.255.255.0
!
int loopback 4
ip address 30.1.4.1 255.255.255.0
!


Interface level Configuration
=================================
R4
============
config t
hostname R4
int e2/0
description **Connection to R2**
no shut
ip address 24.1.1.4 255.255.255.0
!
int e2/1
description **Connection to R5**
no shut
ip address 45.1.1.4 255.255.255.0
!
int e2/3
description **Connection to R6**
no shut
ip address 46.1.1.4 255.255.255.0
!
int loopback 0
ip address 4.4.4.4 255.255.255.255
!
int loopback 1
ip address 40.1.1.1 255.255.255.0
!
int loopback 2
ip address 40.1.2.1 255.255.255.0
!
int loopback 3
ip address 40.1.3.1 255.255.255.0
!
int loopback 4
ip address 40.1.4.1 255.255.255.0
!

Interface level Configuration
=================================
R5
============
config t
hostname R5
int e2/0
description **Connection to R4**
no shut
ip address 45.1.1.5 255.255.255.0
!
int e2/1
description **Connection to R3**
no shut
ip address 35.1.1.5 255.255.255.0
!
int loopback 0
ip address 5.5.5.5 255.255.255.255
!
int loopback 1
ip address 50.1.1.1 255.255.255.0
!
int loopback 2
ip address 50.1.2.1 255.255.255.0
!
int loopback 3
ip address 50.1.3.1 255.255.255.0
!
int loopback 4
ip address 50.1.4.1 255.255.255.0
!

Interface level Configuration
=================================
R6
============
config t
hostname R6
int e2/3
description **Connection to R4**
no shut
ip address 46.1.1.6 255.255.255.0
!
int loopback 0
ip address 6.6.6.6 255.255.255.255
!
int loopback 1
ip address 60.1.1.1 255.255.255.0
!
int loopback 2
ip address 60.1.2.1 255.255.255.0
!
int loopback 3
ip address 60.1.3.1 255.255.255.0
!
int loopback 4
ip address 60.1.4.1 255.255.255.0
!

===============================================================



R1
config t
ip route 2.2.2.2 255.255.255.255 12.1.1.2
ip route 2.2.2.2 255.255.255.255 21.1.1.2

R2
config t
ip route 1.1.1.1 255.255.255.255 12.1.1.1
ip route 1.1.1.1 255.255.255.255 21.1.1.1

R3
config t
router eigrp 10
network 35.1.1.0 0.0.0.255
network 30.1.1.0 0.0.0.255
network 30.1.2.0 0.0.0.255
network 30.1.3.0 0.0.0.255
network 30.1.4.0 0.0.0.255

R4
config t
router eigrp 10
network 45.1.1.0 0.0.0.255
network 40.1.1.0 0.0.0.255
network 40.1.2.0 0.0.0.255
network 40.1.3.0 0.0.0.255
network 40.1.4.0 0.0.0.255

R5
config t
router eigrp 10
network 35.1.1.0 0.0.0.255
network 45.1.1.0 0.0.0.255
network 50.1.1.0 0.0.0.255
network 50.1.2.0 0.0.0.255
network 50.1.3.0 0.0.0.255
network 50.1.4.0 0.0.0.255

=========================================================
OUTPUT
=========================================================

R3#sh ip ei ne
R3#sh ip ei neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   35.1.1.5                Et2/1                    10 00:26:39   50   300  0  27
R3#
R3#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      40.0.0.0/24 is subnetted, 4 subnets
D        40.1.1.0 [90/435200] via 35.1.1.5, 00:18:44, Ethernet2/1
D        40.1.2.0 [90/435200] via 35.1.1.5, 00:18:44, Ethernet2/1
D        40.1.3.0 [90/435200] via 35.1.1.5, 00:18:44, Ethernet2/1
D        40.1.4.0 [90/435200] via 35.1.1.5, 00:18:42, Ethernet2/1
      45.0.0.0/24 is subnetted, 1 subnets
D        45.1.1.0 [90/307200] via 35.1.1.5, 00:26:44, Ethernet2/1
      50.0.0.0/24 is subnetted, 4 subnets
D        50.1.1.0 [90/409600] via 35.1.1.5, 00:18:28, Ethernet2/1
D        50.1.2.0 [90/409600] via 35.1.1.5, 00:18:28, Ethernet2/1
D        50.1.3.0 [90/409600] via 35.1.1.5, 00:18:28, Ethernet2/1
D        50.1.4.0 [90/409600] via 35.1.1.5, 00:18:27, Ethernet2/1


R4#sh ip ei neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   45.1.1.5                Et2/1                    12 00:27:36   49   294  0  26
R4#
R4#
R4#sh ip route ei
R4#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      30.0.0.0/24 is subnetted, 4 subnets
D        30.1.1.0 [90/435200] via 45.1.1.5, 00:23:11, Ethernet2/1
D        30.1.2.0 [90/435200] via 45.1.1.5, 00:22:47, Ethernet2/1
D        30.1.3.0 [90/435200] via 45.1.1.5, 00:22:32, Ethernet2/1
D        30.1.4.0 [90/435200] via 45.1.1.5, 00:22:24, Ethernet2/1
      35.0.0.0/24 is subnetted, 1 subnets
D        35.1.1.0 [90/307200] via 45.1.1.5, 00:27:38, Ethernet2/1
      50.0.0.0/24 is subnetted, 4 subnets
D        50.1.1.0 [90/409600] via 45.1.1.5, 00:19:23, Ethernet2/1
D        50.1.2.0 [90/409600] via 45.1.1.5, 00:19:23, Ethernet2/1
D        50.1.3.0 [90/409600] via 45.1.1.5, 00:19:23, Ethernet2/1
D        50.1.4.0 [90/409600] via 45.1.1.5, 00:19:22, Ethernet2/1
R4#


R5#sh ip ei neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   45.1.1.4                Et2/0                    14 00:28:11  188  1128  0  14
0   35.1.1.3                Et2/1                    11 00:28:11  214  1284  0  13
R5#
R5#
R5#
R5#
R5#sh ip route eig
R5#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      30.0.0.0/24 is subnetted, 4 subnets
D        30.1.1.0 [90/409600] via 35.1.1.3, 00:23:48, Ethernet2/1
D        30.1.2.0 [90/409600] via 35.1.1.3, 00:23:24, Ethernet2/1
D        30.1.3.0 [90/409600] via 35.1.1.3, 00:23:10, Ethernet2/1
D        30.1.4.0 [90/409600] via 35.1.1.3, 00:23:02, Ethernet2/1
      40.0.0.0/24 is subnetted, 4 subnets
D        40.1.1.0 [90/409600] via 45.1.1.4, 00:20:16, Ethernet2/0
D        40.1.2.0 [90/409600] via 45.1.1.4, 00:20:16, Ethernet2/0
D        40.1.3.0 [90/409600] via 45.1.1.4, 00:20:16, Ethernet2/0
D        40.1.4.0 [90/409600] via 45.1.1.4, 00:20:14, Ethernet2/0