Saturday 18 April 2020

HSRP TSHOOT TICKET

HSRP TSHOOT TICKET 
R1#SH RUN

Building configuration...

Current configuration : 1775 bytes

!

! Last configuration change at 07:17:29 UTC Thu Dec 6 2018

! NVRAM config last updated at 07:17:30 UTC Thu Dec 6 2018

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no logging console

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

ip sla monitor 1

 type echo protocol ipIcmpEcho 13.1.1.2 source-ipaddr 13.1.1.1

 frequency 5

ip sla monitor schedule 1 start-time now

ip sla monitor 2

 type echo protocol ipIcmpEcho 13.2.1.2 source-ipaddr 13.2.1.1

 frequency 5

ip sla monitor schedule 2 start-time now

!

!

!

!

!

track 100 rtr 1

!

track 200 rtr 2

!

!

interface FastEthernet0

 description LAN

 ip address 192.168.1.2 255.255.255.0

 speed auto

 standby 10 ip 192.168.1.1

 standby 10 priority 115

 standby 10 preempt

 standby 10 track 100

 standby 10 track 200

!

interface Serial0

 description Link1

 ip address 13.1.1.1 255.255.255.252

 no fair-queue

!

interface Serial1

 description Link2

 ip address 13.2.1.1 255.255.255.252

!

interface Serial2

 no ip address

 shutdown

!

interface Serial3

 no ip address

 shutdown

!

ip forward-protocol nd

ip route 3.3.3.3 255.255.255.255 13.1.1.2 50 name PROD_APP_PRIMARY_PATH

ip route 3.3.3.3 255.255.255.255 13.2.1.2 60 name PROD_APP_SEC_PATH

ip route 4.4.4.4 255.255.255.255 FastEthernet0

ip route 5.5.5.5 255.255.255.255 Serial0 10 name paygmserver

ip route 5.5.5.5 255.255.255.255 Serial1 20 name paygmserver

ip route 24.0.0.0 255.0.0.0 FastEthernet0

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

line aux 0

line vty 0 4

 login

!

end

 R1#  SH STANDby BRief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  115  P Active   local           unknown         192.168.1.1



R2#SH RUN

Building configuration...



Current configuration : 1402 bytes

!

! Last configuration change at 07:17:32 UTC Thu Dec 6 2018

! NVRAM config last updated at 07:17:33 UTC Thu Dec 6 2018

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

no logging console

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

interface FastEthernet0

 description LAN

 ip address 192.168.1.3 255.255.255.0

 speed auto

 standby 20 ip 192.168.1.1

 standby 20 preempt

!

interface Serial0

 description Link3

 ip address 24.1.1.1 255.255.255.252

 shutdown

 no fair-queue

!

interface Serial1

 description Link4

 ip address 24.2.1.1 255.255.255.252

!

interface Serial2

 no ip address

 shutdown

!

interface Serial3

 no ip address

 shutdown

!

ip forward-protocol nd

ip route 3.3.3.3 255.255.255.255 FastEthernet0

ip route 4.4.4.4 255.255.255.255 24.1.1.2 50 name UAT_APP_SERVER

ip route 4.4.4.4 255.255.255.255 24.2.1.2 60 name UAT_APP_SERVER

ip route 5.5.5.5 255.255.255.255 Serial0 10 name paygmserver

ip route 5.5.5.5 255.255.255.255 Serial1 20 name paygmserver

ip route 13.0.0.0 255.0.0.0 FastEthernet0

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

line aux 0

line vty 0 4

 login

!

end

 R2#                 SH STANDby BRIef

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         20  100  P Active   local           unknown         192.168.1.1

R2#





Tshoot


- Checking HSRP Interface status

- Pinging HSRP IP address

- Comparing the HSRP Interface Configuration .


on R1

==============



R1#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              192.168.1.2     YES NVRAM  up                    up

Serial0                    13.1.1.1        YES NVRAM  up                    up

Serial1                    13.2.1.1        YES NVRAM  up                    up

Serial2                    unassigned      YES NVRAM  administratively down down

Serial3                    unassigned      YES NVRAM  administratively down down

R1#

Dec  9 05:10:12.927: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac14

Dec  9 05:10:43.907: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac14

Dec  9 05:11:14.815: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac14

R1#

R1#

R1#

R1#

R1#

R1#

R1#

R1#ping 192.168.1.3



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

.!!!!



R2#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              192.168.1.3     YES NVRAM  up                    up

Serial0                    24.1.1.1        YES NVRAM  administratively down down

Serial1                    24.2.1.1        YES NVRAM  up                    up

Serial2                    unassigned      YES NVRAM  administratively down down

Serial3                    unassigned      YES NVRAM  administratively down down



R2#ping 192.168.1.2



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/40 ms

R2#



Checking HSRP Interface configuration



R1#sh run int fa

Dec  9 05:12:45.931: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac140

Building configuration...



Current configuration : 214 bytes

!

interface FastEthernet0

 description LAN

 ip address 192.168.1.2 255.255.255.0

 speed auto

 standby 10 ip 192.168.1.1

 standby 10 priority 115

 standby 10 preempt

 standby 10 track 100

 standby 10 track 200

end



R2#sh run int fa0

Building configuration...



Current configuration : 145 bytes

!

interface FastEthernet0

 description LAN

 ip address 192.168.1.3 255.255.255.0

 speed auto

 standby 20 ip 192.168.1.1

 standby 20 preempt

end



===============================================================



INCORRECT HSRP GROUP CONFIGURED ON R2

================================================================



R2#

Dec  9 05:15:15.691: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac0a

R2#config

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#int fa0

R2(config-if)#stan

R2(config-if)#standby 10 ip 192.168.1.1

% Address 192.168.1.1 in group 20

R2(config-if)#

Dec  9 05:15:45.799: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac0a

Dec  9 05:16:15.831: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac0a

Dec  9 05:16:45.879: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac0a

Dec  9 05:17:15.895: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on FastEthernet0, sourced by 0000.0c07.ac0a

R2(config-if)#

R2(config-if)#

R2(config-if)#

R2(config-if)#

R2(config-if)#no standby 20 ip 192.168.1.1

R2(config-if)#no standby 20 preempt

R2(config-if)#standby 10 ip 192.168.1.1

R2(config-if)#standby 10 preempt

R2(config-if)#

Dec  9 05:17:38.399: %HSRP-5-STATECHANGE: FastEthernet0 Grp 20 state Active -> Disabled^Z

R2#

R2#

R2#

R2#

Dec  9 05:17:40.335: %SYS-5-CONFIG_I: Configured from console by console

R2#sh stand

R2#sh standby br

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Listen   192.168.1.2     unknown         192.168.1.1

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Speak    192.168.1.2     unknown         192.168.1.1

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Speak    192.168.1.2     unknown         192.168.1.1

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Speak    192.168.1.2     unknown         192.168.1.1

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Speak    192.168.1.2     unknown         192.168.1.1

R2#sh standby brief

Dec  9 05:18:09.411: %HSRP-5-STATECHANGE: FastEthernet0 Grp 10 state Speak -> Standby

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  100  P Standby  192.168.1.2     local           192.168.1.1

R2#



let's check on R1



R1#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP

Fa0         10  115  P Active   local           192.168.1.3     192.168.1.1



Showing the required results



Thanks for the reading the blog !!!!!

No comments:

Post a Comment